Affected
Major outage from 9:00 PM to 7:45 PM
- ResolvedResolved
UPDATE: We were just notified by our underlying fax vendor that all fax services have been restored and are operational as of 2pm Eastern. The backlogged fax queue is now clear and faxing is now operating per normal.
If you notice any issues with your managed fax service, please open a support ticket by calling 248-781-4711 or by sending an email to support@mavenitinc.com.
We appreciate your patience during this outage. We will follow up with future risk mitigation plans in the following days.
Thank you,
Maven IT Service Desk
- UpdateUpdate
UPDATE: Our underlying fax provider has made some significant progress overnight, but doesn't have the fax service 100% back online as of yet. An new ETA for service restoration is pending.
We will send an additional update once we have more information.
Thank you,
Maven IT Service Desk Team
- UpdateUpdate
UPDATE: Our underlying fax vendor has updated service restoration to Wednesday morning, 7/26. We will send an additional update once the fax service is back online.
Again, we appreciate your patience and understanding.
Thank you,
Maven IT Service Desk Team
- UpdateUpdate
Maven IT Managed Fax Users:
Please be aware that our underlying fax provider has identified an issue with both inbound and outbound faxing. Our provider stated that the issue began Monday, July 24th, at approximately 5pm Eastern.
Our provider is currently working on correcting the issue and estimates that faxing will be back online by the end of the day, today, July 25th.
Maven IT will send additional notifications as information is received.
We appreciate your patience and understanding. Please feel free to contact our Service Desk Team at 248-781-4711 should you need further assistance.
Thank you,
Maven IT Service Desk Team
- IdentifiedIdentified
Maven IT Managed Fax Users:
Please be aware that our underlying fax provider has identified an issue with both inbound and outbound faxing. Our provider stated that the issue began Monday, July 24th, at approximately 5pm Eastern.
Our provider is currently working on correcting the issue and estimates that faxing will be back online by the end of the day, today, July 25th.
Maven IT will send additional notifications as information is received.
We appreciate your patience and understanding. Please feel free to contact our Service Desk Team at 248-781-4711 should you need further assistance.
Thank you,
Maven IT Service Desk Team
![[object Object]](/_next/image?url=https%3A%2F%2Finstatus.com%2Fuser-content%2Fv1690295436%2Fl2yxwtbnaks88bfmjlgv.png&w=3840&q=75)